• Страница 1 из 1
  • 1
Форум о визуальных новеллах » Для разработчиков » Ren'Py » Мелодия, где моя мелодия, RenPy? (play music не работает)
Мелодия, где моя мелодия, RenPy?

lighthouse_37

#1
Вот фрагмент до ужаса простого кода:

init:

$ mods["letter_label"]=u"Tartar"

$ prologue = "mods/Tartar/MusiCore/Prologue.ogg"

image bg hello = "mods/Tartar/ImaCore/hello.jpg"

$ sfx_wrapping = "mods/Tartar/SouCore/wrap.wav"

label letter_label:
$ set_mode_nvl()
play music "prologue"
scene bg hello
play sound sfx_wrapping

Ошибок код не выдаёт, но музыки нет. Путь верный. Формат менял на OGG с MP3. Аудиозапись рабочая. Я не знаю. Помогите.

lighthouse_37

#5
Цитата dmit ()
ну тогда в лоб - почему sfx_wrapping без кавычек, а "prologue" с кавычками - непорядок!!!


Без кавычек точно также не работает. Ошибка не в синтаксисе, иначе RenPy мне бы голову откусил. Тут какой-то другой непорядок. Без кавычек ровно то же самое.

lighthouse_37

#6
Я занялся дебагингом и выяснил, что проблема не в вызове команды, а в указании пути, ибо компилятор не реагирует даже на неправильный путь до файла.

Буду разбираться, на первый взгляд всё верно...

lighthouse_37

#7
Господа, я нашёл ошибку. Для тех, у кого похожая проблема, объясню: смените название переменной. Вероятнее всего, в оригинальной игре уже существовала переменная prologue, из-за чего компилятор игнорировал её переназначение.
Форум о визуальных новеллах » Для разработчиков » Ren'Py » Мелодия, где моя мелодия, RenPy? (play music не работает)
  • Страница 1 из 1
  • 1
Поиск: